最新 | 最热门 | 最高评价

+0  在macOS下用homebrew安装php 7.1以及pecl

Tag: php | homebrew | macOS
Volcano 发于 2017年07月25日 21:29 | 点击: 1079 | 展开摘要
用homebrew默认安装的php 7.1没有包含pecl命令。但是重新安装可以解决这个问题,如果出现libpng不兼容问题,可以加上-s参数 brew remove php71 brew install php71 --with-pear

查看全文: http://www.udpwork.com/item/16362.html

+0  homebrew使用socks-proxy

Tag: macosx | curl | homebrew | socks
suchasplus 发于 2014年12月08日 02:37 | 点击: 2110 | 展开摘要
国庆给MacMini加装了块SSD, 直接重装了系统,用Mac Homebrew安装各种GNU工具ing

托GFVV的福, 不但login.live.com和yahoo.com的SSL被MITM了, 连homebrew去sf.net和github.com下载源码都会被干扰SSL握手

迫不得已用proxy...

homebrew使用curl,  所以直接给curl加proxy就行了

curl --socks5-hostname 127.0.0.1:1080 ip.cn查

查看全文: http://www.udpwork.com/item/13362.html

+0  Using Homebrew Over Socks5

Tag: socks5 | github | homebrew
C.C. 发于 2013年09月08日 00:00 | 点击: 825 | 展开摘要
這兩天Github貌似被功夫牆了,所以導致brew update這樣的命令會失效,如果homebrew不能用,那可損失大了。

通過brew update -v能看到是卡在了git pull的操作上,好在git現在的版本支持proxy了,操作方式也很簡單:

cd /usr/local && git config http.proxy 'socks5://127.0.0.1:7070'

然後執行brew update,順利通過。

查看全文: http://www.udpwork.com/item/12893.html

+0  使用xctool自动打包,测试xcode项目

Tag: objective-c | facebook | homebrew | xcode
Volcano 发于 2013年05月14日 17:17 | 点击: 2629 | 展开摘要
xctool是facebook开源的一个命令行工具,用来替代苹果的xcodebuild工具。 功能如下: 像xcode一样跑测试用例 结构化输出编译测试结果 彩色且方便阅读的编译内容输出 示例截图: 如何安装xctool 最简单的办法是通过homebrew安装xctool brew update brew install xctool 搞定 如何使用xctool 打包 path/to/xctool.sh -workspace YourWorkspace.xcworkspace

查看全文: http://www.udpwork.com/item/9841.html

+0  mac下快速安装php 5.4

Tag: php | homebrew | mac
Volcano 发于 2012年08月03日 10:39 | 点击: 1932 | 展开摘要
手头的笔记本升级到了OS X 10.8了,但是偶尔还需要写点php调剂一下。看看自带的php版本? PHP 5.3.13 with Suhosin-Patch (cli) (built: Jun 20 2012 17:05:20) Copyright (c) 1997-2012 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies 对于追新族来说,必须得升级到php 5.4才开心

查看全文: http://www.udpwork.com/item/7862.html

+0  Mac下memcached的安装和使用

Tag: Apple | Programming | Tips | 技术文章 | HomeBrew | libmemcached | memcached | pylibmc
何 李石 发于 2011年09月08日 22:05 | 点击: 3220 | 展开摘要
1. 安装memcached

我们在python环境下使用pylibmc客户端,这个客户端依赖于libmemcached这个库。在Mac下,直接用homebrew安装libmemcached,它会自动安装memcached:

brew install libmemcached

版本有点老,但不要紧。

2. 安装pylibmc客户端

用easy_install,事先声明libmemcached的地址:

sudo LIBMEMCACHED=/usr/local/Cel

查看全文: http://www.udpwork.com/item/5768.html

+0  Mac上安装MySQL报错

Tag: Apple | Programming | 技术文章 | Google搜索 | HomeBrew | Mysql
何 李石 发于 2011年06月18日 01:13 | 点击: 2298 | 展开摘要
我尝试过两种方式在Mac上安装MySQL:

HomeBrew

export ARCHFLAGS=”-arch i686 -arch x86_64″

brew install mysql

用brew安装好后,还需要按照这个命令输出的信息进行配置:

brew info mysql

用这种方式安装好后,MySQL没法启动。出现如下错误:

mysql -uroot -p

ERROR 2002 (HY000): Can’t conne

查看全文: http://www.udpwork.com/item/5296.html
|<<<1>>>| 一共1页, 7条记录